summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 7017e08..d457038 100644
--- a/shell.nix
+++ b/shell.nix
@@ -7,6 +7,8 @@ mkShell rec {
name = "android-shell";
buildInputs = [
+ python3Full
+ gnumake
jdk
android-composition.androidsdk
bazel_4
@@ -19,6 +21,6 @@ mkShell rec {
shellHook = ''
# TODO: replace with nix builtins
- sudo python ./nix/android-shell-shellHook.py ${ANDROID_HOME}/build-tools ${ANDROID_HOME}/platforms
+ python ./nix/android-shell-shellHook.py ${ANDROID_HOME}/build-tools ${ANDROID_HOME}/platforms
'';
}