summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorDaniel Weipert <code@drogueronin.de>2023-05-29 09:19:51 +0200
committerDaniel Weipert <code@drogueronin.de>2023-05-29 13:50:38 +0200
commitfde9095587cea432997eb24c3a3f9c61737e2f1e (patch)
tree48e0100948f79bf31739a582e7f8a6d2cb157a66 /shell.nix
parent50fa761d6943e9cd0faef1ea6b801629af5ec889 (diff)
gitlab-ci
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 7017e08..d457038 100644
--- a/shell.nix
+++ b/shell.nix
@@ -7,6 +7,8 @@ mkShell rec {
name = "android-shell";
buildInputs = [
+ python3Full
+ gnumake
jdk
android-composition.androidsdk
bazel_4
@@ -19,6 +21,6 @@ mkShell rec {
shellHook = ''
# TODO: replace with nix builtins
- sudo python ./nix/android-shell-shellHook.py ${ANDROID_HOME}/build-tools ${ANDROID_HOME}/platforms
+ python ./nix/android-shell-shellHook.py ${ANDROID_HOME}/build-tools ${ANDROID_HOME}/platforms
'';
}