diff options
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 13 |
1 files changed, 3 insertions, 10 deletions
@@ -1,26 +1,19 @@ with (import <nixpkgs> {}); let jdk = jdk11; - android-composition = import ./nix/android-composition.nix; + androidsdk = import ./nix/androidsdk.nix; in mkShell rec { name = "android-shell"; buildInputs = [ - python3Full gnumake jdk - android-composition.androidsdk + androidsdk bazel_4 ]; JAVA_HOME = jdk.home; - ANDROID_SDK_ROOT = "${android-composition.androidsdk}/libexec/android-sdk"; - ANDROID_NDK_ROOT = "${ANDROID_SDK_ROOT}/ndk-bundle"; + ANDROID_SDK_ROOT = "${androidsdk}/libexec/android-sdk"; ANDROID_HOME = "${ANDROID_SDK_ROOT}"; - - shellHook = '' - # TODO: replace with nix builtins - python ./nix/android-shell-shellHook.py ${ANDROID_HOME}/build-tools ${ANDROID_HOME}/platforms - ''; } |