diff options
author | Daniel Weipert <code@drogueronin.de> | 2023-06-06 21:05:32 +0200 |
---|---|---|
committer | Daniel Weipert <code@drogueronin.de> | 2023-06-06 21:05:32 +0200 |
commit | 152ec3e0a33816a433867a0c0ba8c6c9fc20f5a8 (patch) | |
tree | 3bbdbf415ba09bc8d92e2e8affb693d7872e7ed2 /shell.nix | |
parent | 93edf37a5b82c0dc52846c28b9e804f6e4352235 (diff) |
Diffstat (limited to 'shell.nix')
-rw-r--r-- | shell.nix | 13 |
1 files changed, 3 insertions, 10 deletions
@@ -1,26 +1,19 @@ with (import <nixpkgs> {}); let jdk = jdk11; - android-composition = import ./nix/android-composition.nix; + androidsdk = import ./nix/androidsdk.nix; in mkShell rec { name = "android-shell"; buildInputs = [ - python3Full gnumake jdk - android-composition.androidsdk + androidsdk bazel_4 ]; JAVA_HOME = jdk.home; - ANDROID_SDK_ROOT = "${android-composition.androidsdk}/libexec/android-sdk"; - ANDROID_NDK_ROOT = "${ANDROID_SDK_ROOT}/ndk-bundle"; + ANDROID_SDK_ROOT = "${androidsdk}/libexec/android-sdk"; ANDROID_HOME = "${ANDROID_SDK_ROOT}"; - - shellHook = '' - # TODO: replace with nix builtins - python ./nix/android-shell-shellHook.py ${ANDROID_HOME}/build-tools ${ANDROID_HOME}/platforms - ''; } |