summaryrefslogtreecommitdiff
path: root/nix/androidsdk.nix
diff options
context:
space:
mode:
authorDaniel Weipert <code@drogueronin.de>2023-06-06 21:05:32 +0200
committerDaniel Weipert <code@drogueronin.de>2023-06-06 21:05:32 +0200
commit152ec3e0a33816a433867a0c0ba8c6c9fc20f5a8 (patch)
tree3bbdbf415ba09bc8d92e2e8affb693d7872e7ed2 /nix/androidsdk.nix
parent93edf37a5b82c0dc52846c28b9e804f6e4352235 (diff)
fix nix androidsdk fixup for consistency between gitlab-ci and localHEADmain
Diffstat (limited to 'nix/androidsdk.nix')
-rw-r--r--nix/androidsdk.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/nix/androidsdk.nix b/nix/androidsdk.nix
new file mode 100644
index 0000000..cf1ea04
--- /dev/null
+++ b/nix/androidsdk.nix
@@ -0,0 +1,29 @@
+with (import <nixpkgs> {});
+let
+ android-composition = import ./android-composition.nix;
+in
+stdenv.mkDerivation {
+ name = "androidsdk";
+
+ buildInputs = [
+ python3Full
+ ];
+
+ src = "${android-composition.androidsdk}";
+
+ dontUnpack = true;
+
+ buildPhase = ''
+ buildDir=$PWD/android-composition
+ mkdir $buildDir
+
+ cp -r $src/* $buildDir
+
+ chmod -R +w "$buildDir/libexec/android-sdk"
+ python ${./androidsdk-fixup.py} "$buildDir/libexec/android-sdk"
+ '';
+
+ installPhase = ''
+ cp -r $buildDir $out
+ '';
+}