summaryrefslogtreecommitdiff
path: root/mobile/nix/androidsdk.nix
diff options
context:
space:
mode:
Diffstat (limited to 'mobile/nix/androidsdk.nix')
-rw-r--r--mobile/nix/androidsdk.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/mobile/nix/androidsdk.nix b/mobile/nix/androidsdk.nix
deleted file mode 100644
index cf1ea04..0000000
--- a/mobile/nix/androidsdk.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-with (import <nixpkgs> {});
-let
- android-composition = import ./android-composition.nix;
-in
-stdenv.mkDerivation {
- name = "androidsdk";
-
- buildInputs = [
- python3Full
- ];
-
- src = "${android-composition.androidsdk}";
-
- dontUnpack = true;
-
- buildPhase = ''
- buildDir=$PWD/android-composition
- mkdir $buildDir
-
- cp -r $src/* $buildDir
-
- chmod -R +w "$buildDir/libexec/android-sdk"
- python ${./androidsdk-fixup.py} "$buildDir/libexec/android-sdk"
- '';
-
- installPhase = ''
- cp -r $buildDir $out
- '';
-}