summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix25
1 files changed, 9 insertions, 16 deletions
diff --git a/shell.nix b/shell.nix
index 767fb3d..7017e08 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,31 +1,24 @@
-with (import <nixpkgs> {
- config.android_sdk.accept_license = true;
-});
+with (import <nixpkgs> {});
let
jdk = jdk11;
- android_composition = androidenv.composeAndroidPackages {
- platformVersions = ["28"];
- };
- #androidsdk = androidenv.androidPkgs_9_0.androidsdk;
- androidsdk = android_composition.androidsdk;
+ android-composition = import ./nix/android-composition.nix;
in
mkShell rec {
+ name = "android-shell";
+
buildInputs = [
jdk
- androidsdk
- #android-studio
- bazel
- python2
- bazel-watcher
- java-language-server
+ android-composition.androidsdk
+ bazel_4
];
JAVA_HOME = jdk.home;
- ANDROID_SDK_ROOT = "${androidsdk}/libexec/android-sdk";
+ ANDROID_SDK_ROOT = "${android-composition.androidsdk}/libexec/android-sdk";
ANDROID_NDK_ROOT = "${ANDROID_SDK_ROOT}/ndk-bundle";
ANDROID_HOME = "${ANDROID_SDK_ROOT}";
shellHook = ''
- echo ":lua require('lspconfig').java_language_server.setup { cmd = { '${java-language-server}/share/java/java-language-server/lang_server_linux.sh' } }"
+ # TODO: replace with nix builtins
+ sudo python ./nix/android-shell-shellHook.py ${ANDROID_HOME}/build-tools ${ANDROID_HOME}/platforms
'';
}