summaryrefslogtreecommitdiff
path: root/nix/gitlab-ci.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/gitlab-ci.nix')
-rw-r--r--nix/gitlab-ci.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/nix/gitlab-ci.nix b/nix/gitlab-ci.nix
new file mode 100644
index 0000000..4fbba37
--- /dev/null
+++ b/nix/gitlab-ci.nix
@@ -0,0 +1,35 @@
+with (import <nixpkgs> {});
+let
+ jdk = jdk11;
+ android-composition = import ./nix/android-composition.nix;
+in
+stdenv.mkDerivation rec {
+ name = "gitlab-ci";
+
+ buildInputs = [
+ python3Full
+ gnumake
+ jdk
+ android-composition.androidsdk
+ bazel_4
+ ];
+
+ src = ./.;
+
+ JAVA_HOME = jdk.home;
+ ANDROID_SDK_ROOT = "${android-composition.androidsdk}/libexec/android-sdk";
+ ANDROID_NDK_ROOT = "${ANDROID_SDK_ROOT}/ndk-bundle";
+ ANDROID_HOME = "${ANDROID_SDK_ROOT}";
+
+ preferLocalBuild = true;
+ dontUnpack = true;
+ buildPhase = ''
+ # TODO: replace with nix builtins
+ python ./android-shell-shellHook.py ${ANDROID_HOME}/build-tools ${ANDROID_HOME}/platforms
+
+ make build -C $src
+ '';
+ installPhase = ''
+ mv $src/bazel-bin/app/java/dnsproxy.apk $out
+ '';
+}