summaryrefslogtreecommitdiff
path: root/gitlab-ci.nix
diff options
context:
space:
mode:
authorDaniel Weipert <code@drogueronin.de>2023-05-29 11:52:15 +0200
committerDaniel Weipert <code@drogueronin.de>2023-05-29 11:52:15 +0200
commitd90d22f68d16d8271e730b642b68cb12665789b7 (patch)
treeb8956d4cddf351faa4a018c326417b0cae372e7e /gitlab-ci.nix
parent6a638c04601552e26be578290b8b1ec98bcf777b (diff)
gitlab-ci
Diffstat (limited to 'gitlab-ci.nix')
-rw-r--r--gitlab-ci.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/gitlab-ci.nix b/gitlab-ci.nix
new file mode 100644
index 0000000..12a176b
--- /dev/null
+++ b/gitlab-ci.nix
@@ -0,0 +1,35 @@
+with (import <nixpkgs> {});
+let
+ jdk = jdk11;
+ android-composition = import ./nix/android-composition.nix;
+in
+stdenv.mkDerivation rec {
+ name = "gitlab-ci";
+
+ buildInputs = [
+ python3Full
+ gnumake
+ jdk
+ android-composition.androidsdk
+ bazel_4
+ ];
+
+ src = ./.;
+
+ JAVA_HOME = jdk.home;
+ ANDROID_SDK_ROOT = "${android-composition.androidsdk}/libexec/android-sdk";
+ ANDROID_NDK_ROOT = "${ANDROID_SDK_ROOT}/ndk-bundle";
+ ANDROID_HOME = "${ANDROID_SDK_ROOT}";
+
+ preferLocalBuild = true;
+ dontUnpack = true;
+ buildPhase = ''
+ # TODO: replace with nix builtins
+ # python ./android-shell-shellHook.py ${ANDROID_HOME}/build-tools ${ANDROID_HOME}/platforms
+
+ make build -C $src
+ '';
+ installPhase = ''
+ mv $src/bazel-bin/app/java/dnsproxy.apk $out
+ '';
+}