summaryrefslogtreecommitdiff
path: root/gitlab-ci.nix
diff options
context:
space:
mode:
authorDaniel Weipert <code@drogueronin.de>2023-05-29 12:49:41 +0200
committerDaniel Weipert <code@drogueronin.de>2023-05-29 12:49:41 +0200
commit8745fd05b0fcff48a1923854183fd6a4516f6e6b (patch)
tree4386469c87daee67ba1abae98a094217c620f6bc /gitlab-ci.nix
parent12549e3e44f746590aaef69bbbbf438d2e9807cc (diff)
gitlab-ci
Diffstat (limited to 'gitlab-ci.nix')
-rw-r--r--gitlab-ci.nix35
1 files changed, 0 insertions, 35 deletions
diff --git a/gitlab-ci.nix b/gitlab-ci.nix
deleted file mode 100644
index 4fbba37..0000000
--- a/gitlab-ci.nix
+++ /dev/null
@@ -1,35 +0,0 @@
-with (import <nixpkgs> {});
-let
- jdk = jdk11;
- android-composition = import ./nix/android-composition.nix;
-in
-stdenv.mkDerivation rec {
- name = "gitlab-ci";
-
- buildInputs = [
- python3Full
- gnumake
- jdk
- android-composition.androidsdk
- bazel_4
- ];
-
- src = ./.;
-
- JAVA_HOME = jdk.home;
- ANDROID_SDK_ROOT = "${android-composition.androidsdk}/libexec/android-sdk";
- ANDROID_NDK_ROOT = "${ANDROID_SDK_ROOT}/ndk-bundle";
- ANDROID_HOME = "${ANDROID_SDK_ROOT}";
-
- preferLocalBuild = true;
- dontUnpack = true;
- buildPhase = ''
- # TODO: replace with nix builtins
- python ./android-shell-shellHook.py ${ANDROID_HOME}/build-tools ${ANDROID_HOME}/platforms
-
- make build -C $src
- '';
- installPhase = ''
- mv $src/bazel-bin/app/java/dnsproxy.apk $out
- '';
-}